Core Configuration of a Router and a Switch in Cisco Packet Tracer – Every Command Explained.
Berg IT Training – In this CCST and CCNA introductory-level video, I perform a line-by-line core configuration of a Cisco router and a Cisco switch using the command line interface (CLI) in Cisco Packet Tracer, explaining each command in detail and verifiying the effects of each command as we go.
We perform all the foundational commands discussed in Cisco’s CCNA: Introduction to Networks version 7 (CCNA 1).
============================================================
Time Stamps
00:00 Video Introduction
00:53 Topology Overview
01:55 Defaut Functionality of a Switch
03:19 Structured Core Configuration Overview
04:20 User EXEC, Privileged EXEC, and Global Configuration Modes
06:50 Configuring the Hostname
07:34 Securing the Device
08:20 Banner MOTD Command
11:04 Device CLI Tab vs Console Cable Terminal Access
12:24 Configuring the Console Password (Line Console 0)
14:29 Understanding the Login command in Line Configuration Mode
16:55 Configuring the VTY Lines Password
20:00 Viewing Plain Text Passwords Using Show Runnning Configuration
20:52 Service Password-Encryption Command
22:45 Enable Password vs Enable Secret Commands
29:10 Understanding Switchports and the Default VLAN 1 on a Switch
31:08 Configuring an IP Address to VLAN 1 on a Switch
35:10 Testing VTY Passwords Using Telnet
36:37 Copy Running-Config Startup-Config
38:44 Applying Text File Configurations to a Router
40:42 Configuring an IP Address to an Interface on a Router
41:49 Summary and Outro
============================================================
============================================================
Text File Configurations Shared in the Video Are in the Video Comments Below
============================================================
My mission with my videos is to provide useful, comprehensive information regarding information technology, infrastructure and computing technology, networking, cybersecurity, local area network management, and IT project management in an engaging and entertaining way.
Like this content? Check out my work-in-progress playlists:
Fundamentals of Local Area Network Management
Journey to CCST (Networking) and CCNA 200-301 (series in progress)
Practical Cybersecurity (series in progress)
#ittraining #ccna #ccst #packettracer #networking
by Troy Berg
simple network management protocol
great new video
Tanks Troy, I really enjoy being here, new stuff new level.
As always Troy, your the best!
Thanks for watching, everyone! As promised, the following is the cut-and-paste configuration we completed in the video for the 3560 switch:
!Switch Core Configuration
!=====================
!Personalize the Device
!=====================BEGIN PASTE
!Move from user exec to privileged exec mode
enable
!Move to global configuration mode
configure terminal
!Configure the hostname
hostname SW01
!Secure the Device
!=====================
!Configure a security banner
banner motd #
===========================================
No bad guys allowed. Authorized Users Only
===========================================#
!Apply console password
line console 0
password pizza
login
exit
!apply vty lines password
line vty 0 15
password remote
login
exit
!Encrypt plain text passwords
service password-encryption
!Apply a plain text password to access priv exec mode
!enable password access
!Apply an encrypted password to access priv exec mode
enable secret shhhhh
!Connect the Device
!=====================
!Configure the management interface
interface vlan 1
ip address 192.168.0.100 255.255.255.0
no shutdown
exit
!=====================END PASTE
!Save my running configuration
copy running-config startup-config
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
The following is the cut-and-paste configuration we completed in the video for the 4321 router:
!Router Core Configuration
!=====================
!Personalize the Device
!=====================BEGIN PASTE
!Move from user exec to privileged exec mode
enable
!Move to global configuration mode
configure terminal
!Configure the hostname
hostname RT01
!Secure the Device
!=====================
!Configure a security banner
banner motd #
===========================================
No bad guys allowed. Authorized Users Only
===========================================#
!Apply console password
line console 0
password pizza
login
exit
!apply vty lines password
line vty 0 15
password remote
login
exit
!Encrypt plain text passwords
service password-encryption
!Apply a plain text password to access priv exec mode
!enable password access
!Apply an encrypted password to access priv exec mode
enable secret shhhhh
!Connect the Device
!=====================
!Configure the management interface
interface g0/0/0
ip address 192.168.0.254 255.255.255.0
no shutdown
exit
!=====================END PASTE
!Save my running configuration
copy running-config startup-config